Страница 1 из 11
Модератор форума: lyumer, Екатерина_Пашкова 
Форум учителей об образовании в России и мире » Архив » "Компьютерная тема" » Формулы в эксель (формула если)
Формулы в эксель
siminiva_yulyaДата: Вторник, 10.07.2012, 16:50 | Сообщение # 1

Юлия Симонова
Ранг: Дошколенок (?)
Группа: Зарегистрированные
Российская Федерация
Самара

Сообщений:
1
Награды: 0
Статус: Offline
Здравствуйте. Помогите мне пожалуйста, я создала тест в экселе, состоящий из 7 вопросов. Мне нужно составить формулу, которая будет выставлять оценки ученику. если 0,1,2 правильных ответов- неуд, если 3-удовл, если 4,5,6-хоррошо, если 7-отлично.
Я пробовала составлять формулу- вот она. =ЕСЛИ(0≤A1≤2;"неудовлетворительно";ЕСЛИ(A1=3;"удовлетворительно";ЕСЛИ(4≤A1≤5;"хорошо";ЕСЛИ(6≤A1≤7;"отлично"))))
Но она не работает((((
Помогите пожалуйста, завтра практику сдавать
Спасибо
miflinДата: Вторник, 10.07.2012, 19:36 | Сообщение # 2

Ранг: Профессор (?)
Хмырь обыкновенный
Группа: Пользователи
Украина
Зугрэс

Сообщений:
2557
Награды: 84
Статус: Offline
=ЕСЛИ(И(A1>=0;A1<=7);ЕСЛИ(A1<3;"неуд";ЕСЛИ(A1=3;"уд";ЕСЛИ(A1<=6;"хор";"отл")));"")
Спасибо
miflinДата: Четверг, 12.07.2012, 21:41 | Сообщение # 3

Ранг: Профессор (?)
Хмырь обыкновенный
Группа: Пользователи
Украина
Зугрэс

Сообщений:
2557
Награды: 84
Статус: Offline
Во, маладёш пашла. Даже слово "пасибки" не знает.
lol
Помню, веду свою четырехлетнюю (чуть меньше) дочку в больницу, чтобы взять справку
у врача для продолжения посещения садика. По пути наставляю:
зайдем в кабинет - скажешь тёте "здравствуйте", когда тётя даст справочку -
скажешь "спасибо".
Заходим в кабинет - дитё стушевалось и "здравствуйте" не произнесло.
Врач выписывает справку, я говорю - дайте ей в руки.
Дитё справку приняло. Я: "Саша, что надо сказать?"
Саша: "Здравствуйте!"
smile
Ей-богу, не выдумал!
Спасибо
Сергеев_ЕВДата: Воскресенье, 15.07.2012, 09:56 | Сообщение # 4

Евгений
Ранг: Первоклашка (?)
Группа: Пользователи
Российская Федерация
Миньяр

Должность: Информатика
Сообщений:
50
Награды: 1
Статус: Offline
Quote (siminiva_yulya)
=ЕСЛИ(0≤A1≤2;"неудовлетворительно";ЕСЛИ(A1=3;"удовлетворительно";ЕСЛИ(4≤A1≤5;"хорошо";ЕСЛИ(6≤A1≤7;"отлично"))))
А лучше воспользоваться функцией ВПР. Создаем список, типа:
Code
1  |  Совсем никуда
2 |  Неудовлетворительно
3 |  Удовлетворительно
4 |  Хорошо
5 |  Отлично

а в нужной ячейке пишем что-то вроде: =ВПР(B7;A1:B5;2;ЛОЖЬ). ВПР - это функция вертикального просмотра таблицы, синяя ячейка - адрес той ячейки, где будет отображаться цифра от 1 до 5, оранжевый диапазон - таблица, по которой будет происходить поиск соответствующего значения, зеленая двойка - номер столбца в этой таблице, из которого нужно брать выводимые данные, ну а красное слово ЛОЖЬ - флаг, говорящий, что интервальный просмотр делать не нужно.

Читаем справку...
Спасибо
Форум учителей об образовании в России и мире » Архив » "Компьютерная тема" » Формулы в эксель (формула если)
Страница 1 из 11
Поиск:



Спорная ситуация с родителями или администрацией? Ищете выход из проблемы на уроке или с учеником?
Не знаете, как что-то сделать на компьютере?


Вы можете задать анонимный вопрос
х
Подробно изложите суть вашего вопроса.
Обратите внимание, что вопросы публикуются в открытом доступе не сайте, поэтому не указывайте персональные данные ваши или иных лиц. Однако стоит указать свой РЕГИОН, т.к. законодательство в разных регионах разное.
Отправить