Решение транспортных задач на уроках информатики 10-11 классы


Автор: Нестеренко Олеся Викторовна

Место работы: г. Калининград МАОУ СОШ №45

Должность: учитель математики и информатики


Тема: Решение транспортных задач на уроках информатики (пример решения задачи)


Задача №10. Целью решения транспортной задачи является нахождение плана грузоперевозок, чтобы общие затраты по перевозкам были минимальными. Пусть дана классическая транспортная задача с тремя поставщиками и пятью потребителями.

Поставщики

Мощность поставщиков

Потребители и их спрос

1

2

3

4

5

190

100

120

110

130

1

200

28

27

18

27

24

2

250

18

26

27

32

21

3

200

27

33

23

31

34


Решение:

Данные и решение в Excel к задаче 10

Вводим исходные данные в Excel.

Для решения данной задачи построим ее математическую модель. Неизвестными в данной задаче являются объемы перевозок. Пусть
xij объем пере­возок, а сij – стоимость перевозки единицы продукции с i-й фабрики на j-й склад соответственно. Функция цели – это сум­марные транспортные расходы, которые следует минимизировать, т.е.:

min. (1)

Неизвестные xij должны удовлетворять ограниче­ниям. Так как модель сбалансирована, то вся продукция должна быть вывезена с фабрик

j [1, 3], (2)

а потребности всех центров распределения должны быть пол­ностью удовлетворены:

i [1, 5]. (3)

Объемы перевозок не должны быть отрицательными:

xij i [1, 3], j [1, 5]. (4)

Здесь аi – объем производства на i-й фабрике, bj – спрос в j-м центре распре­деления.


Рабочий лист EXCEL с введенными исходными данными для решения транспортной задачи  показан на рис 1. (На рис 1-3 показан алгоритм решения типичной задачи).


Рис.1

Затем настраиваем программу «Поиск решения» как показано на рис. 2

Выбираем команду Сервис, Поиск решения и заполняем открывшееся диалоговое окно Поиск решения.


Рис.2

В появившемся окне "Поиск решения" установите курсор на кнопку "Выполнить" и щелкните левой клавишей мыши.

После того как на рабочем листе появилось решение (рис.3) в появившемся диалоговом окне "Результаты поиска решения"

установите курсор на переключатель "Восстановить исходные значения" и щелкните левой клавишей мыши. Для завершения расчетов щелкните на кнопке ОК.

Рис.3


Рис.4


Для решения этой задачи с помощью средства поиска решений введем дан­ные из задачи 10, как показано на рис.


P.S. По умолчанию в Excel надстройка Поиск решения отключена. Чтобы активизировать ее в Excel 2007, щелкните значок Кнопка Microsoft Office , щелкните Параметры Excel, а затем выберите категорию Надстройки. В поле Управление выберите значение Надстройки Excel и нажмите кнопку Перейти. В поле Доступные надстройки установите флажок рядом с пунктом Поиск решения и нажмите кнопку ОК.

В Excel 2003 и ниже выберите команду Сервис/Надстройки, в появившемся диалоговом окне Надстройки установите флажок Поиск решения и щелкните на кнопке ОК. Если вслед за этим на экране появится диалоговое окно с предложением подтвердить ваши намерения, щелкните на кнопке Да. (Возможно, вам понадобится установочный компакт-диск Office).






Таким образом, мы нашли решение рассматриваемой транспортной задачи. Общая стоимость перевозок будет минимальной и равна 15730 ден. ед.

2-й способ в Excel (алгоритм решения транспортной задачи на ЭВМ из учебника А.С. Шапкин, Н.П. Мазаева «Математические методы и модели исследования операций»).

В ячейки А1:E3 введем стоимость перевозок. Ячейки A5: E7 отведены под значения объемов перевозок, пока неизвестных, но здесь появится оптимальный план перевозок. В ячейки G5:G7 введены объемы производства, а в ячейки A9:E9введена потребность (спрос) в продукции в пунктах потребления. В ячейку F8 вводится целевая функция

=СУММПРОИЗВ(A1:E3;A5:E7)

В ячейки A8:Е8 вводятся формулы

=СУММ(A5:A7)

=СУММ(B5:B7)

=СУММ(C5:C7)

=СУММ(D5:D7)

=СУММ(E5:E7)

Определяющие объем продукции, ввозимой в пункты потребления.

В ячейки F5:F7 введены формулы

=СУММ(A5:E5)

=СУММ(A6:E6)

=СУММ(A7:E7),

характеризующие объем производства.

Далее выбираем команду Сервис, Поиск решения и заполняем открывшееся диалоговое окно Поиск решения.

В диалоговом окне Параметры поиска решения установить флажок Линейная модель. После нажатия кнопки Выполнить средство поиска решений находит оптимальный план поставок продукции и соответствующие ему транспортные расходы.







Оптимальное решение транспортной задачи 15730 ден ед.



















Список использованных источников


  1. Высшая математика для экономистов / Под ред. Н.Ш. Кремера. – М.: Банки и биржи, ЮНИТИ, 1997.

  2. Горчаков А.А., Орлова И.В. Компьютерные экономико - математические модели. – М.: Компьютер, ЮНИТИ, 1995.

  3. Ерохин Н.М., Орехов Н.А., Сидоренко А.В. Статистические модели и планирование экспериментов в экономике: Методическое пособие. – Калуга: КФ МГТУ, 1994.

  4. Замков О.О., Толстопятенко А.В., Черемных Ю.Н. Математические методы в экономике. – М., 1997.

  5. Исследование операций / Под ред. М.А. Войтенко и Н.Ш. Кремера. – М.: Экономическое образование, 1992.

  6. Исследование операций в экономике: Учебное пособие для вузов / Н.Ш. Кремер, Б.А. Путко, И.М., И.М. Тришин, М.Н. Фридман; под ред. Проф. Н.Ш. Кремера. – М.: ЮНИТИ-ДАНА, 2004.

  7. Кузнецов А.В., Сакович В.А., Холод Н.И. Высшая математика. Математическое программирование. – Минск: Вышэйшая школа, 1994.

  8. Математическое программирование / Под ред. Н.Ш. Кремера. – М.: Финстатинформ, 1995.

  9. Орехов Н.А., Левин А.Г., Горбунов Е.А. Математические методы и модели в экономике: Учебное пособие для вузов / Под ред. проф. Н.А. Орехова. – М.: ЮНИТИ-ДАНА, 2004.

  10. Орехов Н.А., Сахаров Г.В., Карпушин А.А. Введение в моделирование экономических процессов и явлений. – Калуга: КФ МГЭИ, 1997.

  11. Сборник задач и упражнений по высшей математике: математическое программирование / Под ред. А.В. Кузнецова. – Минск: Высшая школа, 1995.

  12. Эконометрика: Учебник / Под ред. И.И. Елисеевой. – М.: Финансы и статистика, 2001.



Полный текст материала Решение транспортных задач на уроках информатики 10-11 классы смотрите в скачиваемом файле.
На странице приведен фрагмент.
Автор: Нестеренко Олеся Викторовна  lesayau
09.03.2013 0 7321 817

Спасибо за Вашу оценку. Если хотите, чтобы Ваше имя
стало известно автору, войдите на сайт как пользователь
и нажмите Спасибо еще раз. Ваше имя появится на этой стрнице.



А вы знали?

Интересные инструкции по ПК

Лучшие материалы сайта для вас
Оставьте отзыв к материалу:
Всего: 0